<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
  <title>The Return of our Lord Jesus</title>
  <meta http-equiv="content-language" content="en" />
  <meta name="description" content="The name Seventh-day Adventist is pregnant with meaning for those who are faithful to God and are loyal to Him. The name points to the truth it bears..." />
<meta name="keywords" content="Sabbath School,Ellen G. White,end times,Sabbath School commentary,Seventh-day Adventists,The Day of the Lord" />
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
<link rel="shortcut icon" href="/files/favicon.png" type="image/x-icon" />
  <link type="text/css" rel="stylesheet" media="all" href="/sites/all/modules/views/css/views.css?Y" />
<link type="text/css" rel="stylesheet" media="all" href="https://spectrummagazine.org/sites/default/files/css/css_c898bbe392bbea286ce7929dbf49c8c7.css" />
<link type="text/css" rel="stylesheet" media="screen,projection" href="https://spectrummagazine.org/sites/default/files/css/css_1d383a217bd254f2d3cd45796aa3a7e0.css" />
<link type="text/css" rel="stylesheet" media="print" href="https://spectrummagazine.org/sites/default/files/css/css_7f665edd701e491c20dfc8af9c6eb5c3.css" />
  <!--[if lte IE 7]>
    <link rel="stylesheet" href="/blueprint/ie.css" type="text/css" media="screen, projection">
    <link href="css/ie.css" rel="stylesheet"  type="text/css"  media="screen, projection" />
      <![endif]-->
  <!--[if lte IE 6]>
    <link href="css/ie6.css" rel="stylesheet"  type="text/css"  media="screen, projection" />
      <![endif]-->
  <script type="text/javascript">var switchTo5x=false;</script><script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script><script type="text/javascript">stLight.options({publisher:'c99d8e95-4296-40c9-8782-28c5f71e9eb5'});</script>
  <!-- Quick Sprout: Grow your traffic -->
  <script>
  (function(e,t,n,c,r){c=e.createElement(t),c.async=1,c.src=n,
  r=e.getElementsByTagName(t)[0],r.parentNode.insertBefore(c,r)})
  (document,"script","https://cdn.quicksprout.com/qs.js");
  </script>
  <!-- End Quick Sprout -->
  <meta name="google-translate-customization" content="d1caeac92a6111ee-90fb677cac08cbd6-g77f6968da96b6786-14"></meta>
</head>

<body class="not-front not-logged-in page-node node-type-article one-sidebar sidebar-right col-2 ">

<div class="container">
    <a href="https://spectrummagazine.org/conference2018" target="_blank"><img src="/sites/all/themes/blue_prism/img/2018-conference-banner-registernow.jpg" alt="Banner image: Register now for Adventist Forum Anniversary Conference" /></a>
  <div id="header" class="span-24 last">
    <div id="logo" class="span-14">
      <a href="/"><img src="https://spectrummagazine.org/sites/default/files/blue_prism_logo.jpg" /></a>
    </div>
    <div class="span-10 last">
      <div id="topmenu" class="span-10 last">
        <ul id="toplinks" class="headermenu"><li class="menu-890 first"><a href="/about_us" title="About Us">About</a></li>
<li class="menu-891"><a href="/advertising-information-request">Advertise</a></li>
<li class="menu-895"><a href="/contact">Contact</a></li>
<li class="menu-547 last"><a href="/user/login" title="Log in, create new account or request new password." class="popups-form-reload">Subscriber Login</a></li>
</ul>      </div>
      <div class="span-10 last">
        <div id="search-box">
          <form action="/article/2018/06/28/return-our-lord-jesus"  accept-charset="UTF-8" method="post" id="search-theme-form">
<div><div id="search" class="container-inline">
  <div class="form-item" id="edit-search-theme-form-1-wrapper">
 <input type="text" maxlength="128" name="search_theme_form" id="edit-search-theme-form-1" size="15" value="Search" class="form-text NormalTextBox txtSearch" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" />
</div>
<input type="hidden" name="form_build_id" id="form-Zi1rE-gio4hRZIIdrqQgpTW_VVRub8QbxMSlY34DgT4" value="form-Zi1rE-gio4hRZIIdrqQgpTW_VVRub8QbxMSlY34DgT4"  />
<input type="hidden" name="form_id" id="edit-search-theme-form" value="search_theme_form"  />
</div>

</div></form>
        </div>
      </div>
      <div id="topnav" class="span-10 last">
        <ul id="topnav" class="headermenu"><li class="expanded first"><a href="http://adventistforum.org" class="forum_menuitem">Forum</a><ul class="menu"><li class="leaf first"><a href="http://adventistforum.org/page/adventist-forum-chapters" class="forum_menuitem">Chapters</a></li>
<li class="leaf last"><a href="/store/membership" class="forum_menuitem">Membership</a></li>
</ul></li>
<li class="expanded"><a href="/spectrum" title="The Spectrum Journal" class="journal_menuitem">Journal</a><ul class="menu"><li class="leaf first"><a href="/journal/current" class="journal_menuitem">Current Issue</a></li>
<li class="leaf"><a href="https://spectrummagazine.org/spectrum_magazine_archives" class="journal_menuitem">Archive</a></li>
<li class="leaf last"><a href="/request_complimentary_subscription" title="Receive your FREE copy today!" class="journal_menuitem">Free Issue</a></li>
</ul></li>
<li class="expanded"><a href="http://www.spectrummagazine.org" class="online_menuitem">Spectrum</a><ul class="menu"><li class="leaf first"><a href="/authors" title="Author Index" class="online_menuitem">Author Index</a></li>
<li class="leaf"><a href="/recent_posts" class="online_menuitem">Recent Posts</a></li>
<li class="leaf last"><a href="/support_spectrum" title="Support Spectrum">Support</a></li>
</ul></li>
<li class="expanded last"><a href="http://spectrummagazine.org/store/af" class="store_menuitem">Store</a><ul class="menu"><li class="leaf first"><a href="http://spectrummagazine.org/store/af" class="store_menuitem">Merchandise</a></li>
<li class="leaf last"><a href="http://adventistforum.org/store/membership" class="store_menuitem">Subscribe</a></li>
</ul></li>
</ul>      </div>
    </div>
    <div class="span-24 last">
      <ul id="sectionnav" class="headermenu"><li class="menu-14473 first"><a href="/news">News</a></li>
<li class="menu-14465"><a href="/voices">Voices</a></li>
<li class="menu-916"><a href="/sabbath-school">Sabbath School</a></li>
<li class="menu-921"><a href="/spirituality">Spirituality</a></li>
<li class="menu-14559"><a href="/gc2015">GC 2015</a></li>
<li class="menu-14486"><a href="/education">Education</a></li>
<li class="menu-918"><a href="/columns">Columns</a></li>
<li class="menu-919"><a href="/interviews">Interviews</a></li>
<li class="menu-14512 last"><a href="/healthcare">Health care</a></li>
</ul>    </div>
    <div id="header_prism_image" class="span-24 last"></div>
  </div><!-- /#header -->

  <div class="span-16">
    <div class="breadcrumb"><a href="/">Home</a> &rsaquo; <a href="/sabbath-school">Sabbath School</a> &rsaquo; The Return of our Lord Jesus</div><h2 class="title">The Return of our Lord Jesus</h2>
  	<div class="span-16 last">
  	    	</div>

  	<div class="span-16 last">
  	  <div id="node-8857" class="node clear-block">


<div class="node-top-links"><div class="submitted"><span class="timestamp">28 June 2018</span> | <span class="authors"><a href="/authors/youssry-guirguis">Youssry Guirguis</a></span></div> 	<span class="print_html"><a href="https://spectrummagazine.org/print/8857" title="Display a printer-friendly version of this page." class="print-page" onclick="window.open(this.href); return false" rel="nofollow"><img src="/sites/all/modules/print/icons/print_icon.gif" alt="Print" title="Print" width="16" height="16" class="print-icon print-icon-margin" />Print</a></span> 	<span class='st_email' displayText='Email'></span>
 	<span class='st_twitter' displayText='Tweet'></span>
 	<span class='st_facebook' displayText='FB'></span>
 	<span class='st_sharethis' displayText='ShareThis'></span>
      <div id="google_translate_element"></div>
    <script type="text/javascript">
      function googleTranslateElementInit() {
        new google.translate.TranslateElement({pageLanguage: 'en', layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL, gaTrack: true, gaId: 'UA-8866094-1'}, 'google_translate_element');
      }
    </script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>
  </div>

  <div class="content clear-block">
    <div class="field field-type-filefield field-field-image">
    <div class="field-items">
            <div class="field-item odd">
                    <img src="https://spectrummagazine.org/sites/default/files/imagecache/large_article_image/China%20door.jpg" alt="" title="" class="imagecache imagecache-large_article_image imagecache-default imagecache-large_article_image_default"/>        </div>
        </div>
</div>
<p><span>The name Seventh-day Adventist is pregnant with meaning for those who are faithful to God and are loyal to Him. The name points to the truth it bears: the words </span><em>Seventh-day</em><span> refers to the Sabbath of the Ten Commandments, a weekly memorial of the creation week. As for the word </span><em>Adventist</em><span>, it points to the second coming of Jesus Christ. Ellen G. White emphasizes that this distinctive holy name is to be made clear to the world till the close of probation She states:</span></p><blockquote><p>A company was presented before me under the name of Seventh-day Adventists, who were advising that the banner or sign which makes us a distinctive people should not be held out so strikingly; for they claimed it was not the best policy in securing success to our institutions. This distinctive banner is to be borne through the world to the close of probation.<sup>1</sup></p></blockquote><p>While bearing the name <em>Adventist</em> does not seem to cause any challenges to the end of time, the bearing of the name <em>Seventh-day</em> will be unpopular. During the time of the implementation of the Sunday Law, it will not be challenging to use the name Adventist, for nearly all Christians believe in the Second Coming of Christ. It is the name <em>Seventh-day</em> that will bring a distinction between those who follow God and those who do not. It is in upholding the name, Seventh-day Adventist that will carry the true distinctive “features of our faith in front, and will convict the inquiring mind. Like an arrow from the Lord's quiver, it will wound the transgressors of God’s law, and will lead to repentance toward God and faith in our Lord Jesus Christ.”<sup>2</sup></p><p>A good example of this situation is found in China, where the China Division of Seventh-day Adventists, with its union and local missions, actually ceased to exist in 1958. However, the Mu En Tang church satisfies the need of long-separated Seventh-day Adventist members to meet as a united body. David Lin states, “about 150 ultra-conservative Seventh-day Adventist members refuse to join the 450 who meet in Mu En Tang. Their objection is that the building is unclean; it is ‘Baal’s altar.’”<sup>3</sup>&nbsp;Their objection centered on the words of Jesus that read, “There is nothing that enters a man from outside which can defile him; but the things which come out of him, those are the things that&nbsp;defile a man” (Mark 7:15). The defilement that Jesus is talking about in Mark 7:15 is not an external factor but rather an internal one.</p><p>After discussing the name Seventh-day Adventist and what it means, the author moves to talk about the <em>Day of the Lord</em>. The Day of the Lord is best accounted for in Isaiah 2:17 “The loftiness of man shall be bowed down, And the haughtiness of men shall be brought low; The Lord alone will be exalted in that day.” The Lord Himself will be exalted in the Day of the Lord. It is said that the Day of the Lord is “dark and foreboding.”<sup>4</sup>&nbsp;Bruce C. Birch sees the Day of the Lord as the day of judgment.<sup>5</sup>&nbsp;But the concept of the Day of the Lord encompasses more than only judgmental or eschatological aspects. It can be used in an eschatological or non-eschatological manner; it can denote a day of judgment or a day of blessing. Hence the eschatological meaning embraced by this idea entails all of the prophetic eschatology. In short, the Day of the Lord involves judgment and salvation. The salvation aspect should never be forgotten.</p><p>The Second Coming of Christ foretold by the prophet Daniel in Chapter 2 is a great Old Testament prophecy.&nbsp; The Bible makes it clear that the stone that hit the image in Daniel 2 represents Jesus Christ, (1 Cor 10:4; Isa 28:16; Lk 20:17,18). Daniel 2:44 states,</p><blockquote><p>And in the days of these kings the God of heaven will set up a kingdom which shall never be destroyed; and the kingdom shall not be left to other people; it shall break in pieces and consume all these kingdoms, and it shall stand forever.” Gerhard Pfandl writes, “The fact that the stone hit the feet and toes of the image indicates that the smiting represents Jesus’ Second Advent at the end of time.<sup>6</sup></p></blockquote><p>Titus 2:13 says, “looking for the blessed hope and glorious appearing of our great God and Savior Jesus Chris.” In this verse, Titus presents the Second Advent with the words “glorious appearing,” that is, a joyous expectation, or in other words, “visible appearance.” “The visible return of Christ is as certain as were His physical birth and His visible ministry.”<sup>7</sup>&nbsp;Here, Paul reminds Titus and all Christians to keep their eyes focus on the Second Advent of Christ.</p><p>Biblical prophecy provides some of the greatest encouragement and hopes available to us today. Just as the Old Testament is saturated with prophecies concerning Christ’s first advent, so both testaments are filled with references to the second coming of Christ. One scholar has estimated that there are 1,845 references to Christ’s second coming in the Old Testament, where seventeen books give it prominence. In the 260 chapters of the New Testament, there are 318 references to the second advent of Christ—an amazing one out of every thirty verses. Twenty-three of the twenty-seven New Testament books refer to this great event. For every prophecy in the Bible concerning Christ’s first advent, there are eight which look forward to His second.<sup>8</sup></p><p>White pictures the coming of Christ in these words,</p><blockquote><p>The firmament appears to open and shut. The glory from the throne of God seems flashing through. The mountains shake like a reed in the wind, and ragged rocks are scattered on every side. There is a roar as of a coming tempest. The sea is lashed into fury. There is heard the shriek of a hurricane like the voice of demons upon a mission of destruction. The whole earth heaves and swells like the waves of the sea. Its surface is breaking up. Its very foundations seem to be giving way. Mountain chains are sinking. Inhabited islands disappear. The seaports that have become like Sodom for wickedness are swallowed up by the angry waters. Babylon the great has come in remembrance before God, ‘to give unto her the cup of the wine of the fierceness of His wrath.’<sup>9</sup></p></blockquote><p>Before Jesus comes the second time, there will be a resurrection of the dead. He said, “I am the resurrection and the life. He who believes in Me, though he may die, he shall live” (John 11:25). Resurrection means to be raised from the dead (John 5:28, 29). The word is used in different contexts in the Bible. Lazarus was raised from the dead (John 11:43). This is a resurrection, but it is not part of the resurrection that occurs when we receive our new bodies when Christ returns (1 Thess 4:13–18) on the last day (John 6:39–44) when the last trumpet is blown (1 Cor 15:51–55). Lazarus died again. The resurrection of Jesus is promissory in that as we know He was raised, so we will be raised also. In that context, Jesus is the only one who has received a resurrected body. That is why He is called the first-fruit from the dead (1 Cor 15:20–23). We will receive our bodies either at the rapture or when Jesus returns to earth.</p><p>The resurrection of Christ is the fundamental article of the Christian faith and the ground-work and proof of all the rest. Job had said: “I know that my redeemer liveth, and that He shall stand at the latter day upon the earth: And…in my flesh shall I see God” (Job 19:25, 26). Daniel said, “Many of them that sleep in the dust of the earth shall awake, some to everlasting life, and some to shame and everlasting contempt” (Dan 12:2). For Paul said, “And if Christ is not risen, your faith is futile; you are still in your sins! Then also those who have fallen asleep in Christ have perished.” (1 Cor 15:17, 18). Such promises referring to some vague “immortality of the soul,” as taught in pagan religions, but to the resurrection of the body!</p><p>&nbsp;</p><p><strong>Notes &amp; References:</strong></p><div id="edn1"><p>1.&nbsp;Ellen G. White,&nbsp;<em>Selected Messages</em>&nbsp;(Washington, DC: Review and Herald, 1958), 2:385.</p></div><div id="edn2"><p>2.&nbsp;Ellen G. White,&nbsp;<em>Testimonies for the</em>&nbsp;Church (Mountain View, CA: Pacific Press, 1948), 1:224. See also Colin D. Standish and Russell R. Standish,&nbsp;<em>Embattled Church</em>&nbsp;(Rapidan, VA: Hartland Publications, 1995), 120-127.</p></div><div id="edn3"><p>3.&nbsp;David Lin,&nbsp;<em>China Letters</em>&nbsp;(Rapidan, VA: Hartland Publications, 1993), 18.</p></div><div id="edn4"><p>4.&nbsp;Paul Grams,&nbsp;<em>Praying the Names of God: A One Year Journey Through the Bible</em>&nbsp;(Bloomington, IN: AuthorHouse, 2005), 384.</p></div><div id="edn5"><p>5.&nbsp;Bruce C. Birch,&nbsp;<em>Hosea, Joel, and Amos</em>&nbsp;(Louisville, KY: Westminster John Knox, 1997), 140.</p></div><div id="edn6"><p>6.&nbsp;Gerhard Pfandl,&nbsp;<em>Study Guide for Jewish Apocalyptic Writings: Daniel</em>&nbsp;(Silver Spring, MD: Home Study International, 2001), 38.</p></div><div id="edn7"><p>7.&nbsp;“Appearing” [1 Timothy 6:14],&nbsp;<em>Seventh-day Adventist Bible Commentary (SDABC)</em>, rev. ed., ed. Francis D. Nichol (Washington, DC: Review &amp; Herald, 1976-1980), 7: 320</p></div><div id="edn8"><p>8.&nbsp;Galaxie Software, 10,000 Sermon Illustrations (Richardson, TX. Biblical Studies Press, 2002), 321.</p></div><div id="edn9"><p>9.&nbsp;Ellen G. White,&nbsp;<em>The Great Controversy</em>&nbsp;(Mountain View, CA:&nbsp; Pacific Press, 1950), 637.</p></div><p>&nbsp;</p><p><em>Image credit: </em><em><a href="https://unsplash.com/photos/16Y4sHHe9xY"><em>Unsplash</em></a></em></p><p><strong><em>We invite you to join our community through conversation by commenting below. We ask that you engage in courteous and respectful discourse. You can view our full commenting policy by&nbsp;</em></strong><a href="https://spectrummagazine.org/page/commenting-policy"><strong><em>clicking here</em></strong></a><strong><em>.</em></strong></p>

          <div id="discourse-comments"></div>

      <script type="text/javascript">
        var discourseUrl = "https://conversation.spectrummagazine.org/",
            discourseEmbedUrl = "http://spectrummagazine.org/node/8857";

        (function() {
          var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
            d.src = discourseUrl + 'javascripts/embed.js';
            // d.src = 'https://conversation.spectrummagazine.org/javascripts/embed.js';
          (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
        })();
      </script>
      </div>


</div>
  	</div>

  </div>

  <div class="span-8 last right">
    <a href="http://www.urbanmissionandministry.org" target="_blank"><img src="/sites/all/themes/blue_prism/img/ads/ummc-ad.jpg" alt="Sidebar image: Click for Urban Mission and Ministry Congress page" /></a>
    <br />
    <br />
	<a href="https://spectrummagazine.org/conference2018" target="_blank"><img src="/sites/all/themes/blue_prism/img/2018-conference-sidebar-registernow.jpg" alt="Sidebar image: Register now for Adventist Forum Anniversary Conference" /></a>
	  <br />
    <br />
    <a href="https://amzn.to/2jHZfPA" target="_blank"><img src="/sites/all/themes/blue_prism/img/ads/glatgf-ad.jpg" alt="Sidebar image: Click for God, Land, and the Flood book" /></a>
    <br />
    <br />
      <div id="block-views-current_issue-block_1" class="block block-views region-odd odd region-count-1 count-1">

  <div class="block-title"><h3>Current Issue</h3></div>

  <div class="content"><div class="view view-current-issue view-id-current_issue view-display-id-block_1 journal-rightblock view-dom-id-4b41d55f1a5db986ebd5a1b78dd51a2d">
    
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image-fid">        <span class="field-content"><a href="/journal/46/2" class="imagecache imagecache-right_block_image imagecache-linked imagecache-right_block_image_linked"><img src="https://spectrummagazine.org/sites/default/files/imagecache/right_block_image/46-2-spectrum-magazine.jpg" alt="" title="" width="242" height="313" class="imagecache imagecache-right_block_image"/></a></span>  </div>  
  <div class="views-field views-field-nothing">        <span class="field-content">Not yet a subscriber? <a href="https://adventistforum.org/store/membership">Subscribe today!</a></span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div></div>
  
</div>
  <div id="block-quicktabs-2" class="block block-quicktabs region-even even region-count-2 count-2">

  <div class="block-title"><h3>Recent</h3></div>

  <div class="content"><div id="quicktabs-2" class="quicktabs_wrapper quicktabs-style-arrows"><ul class="quicktabs_tabs quicktabs-style-arrows"><li class="qtab-0 active first last"><a href="/article/2018/06/28/return-our-lord-jesus?quicktabs_2=0#quicktabs-2" id="quicktabs-tab-2-0" class="qt_tab active">Posts</a></li></ul><div id="quicktabs_container_2" class="quicktabs_main quicktabs-style-arrows"><div id="quicktabs_tabpage_2_0" class="quicktabs_tabpage"><div class="view view-tracker view-id-tracker view-display-id-block_1 view-dom-id-ec6b3834eb03cc1dfd110170cfe417d3">
    
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/28/return-our-lord-jesus" class="active">The Return of our Lord Jesus</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/youssry-guirguis">Youssry Guirguis</a></span>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/28/book-review-protest-and-progress">Book Review: Protest and Progress</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/danielle-barnard">Danielle Barnard</a></span>  </div></li>
          <li class="views-row views-row-3 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/27/adventist-theologians-approve-statement-biblical-eschatology">Adventist Theologians Approve Statement on Biblical Eschatology</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/biblical-research-institute">Biblical Research Institute</a>, <a href="/authors/eud-news">EUD News</a></span>  </div></li>
          <li class="views-row views-row-4 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/27/adventist-pioneers-and-problem-policy-non-compliance">Adventist Pioneers and the Problem of Policy Non-Compliance</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/gilbert-m-valentine">Gilbert M. Valentine</a></span>  </div></li>
          <li class="views-row views-row-5 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/27/loma-linda-university-study-says-adhd-severity-associated-video-game-addiction-se">Loma Linda University study says ADHD severity is associated with video game addiction severity</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/loma-linda-university-health">Loma Linda University Health</a></span>  </div></li>
          <li class="views-row views-row-6 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/26/new-book-tells-about-desmond-dosss-early-years">New Book Tells About Desmond Doss&#039;s Early Years</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/alita-byrd">Alita Byrd</a></span>  </div></li>
          <li class="views-row views-row-7 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/26/supreme-court-religious-animus-irrelevant-trump-travel-ban-case">Supreme Court: Religious Animus Irrelevant In Trump Travel Ban Case</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/michael-peabody">Michael Peabody</a></span>  </div></li>
          <li class="views-row views-row-8 views-row-even">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/26/violence-garment">Violence Like a Garment</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/barry-casey">Barry Casey</a></span>  </div></li>
          <li class="views-row views-row-9 views-row-odd">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/26/senate-chaplain-barry-black-prays-we-love-our-neighbors-ourselves">Senate Chaplain Barry Black Prays That We Love Our Neighbors as Ourselves</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/alisa-williams">Alisa Williams</a></span>  </div></li>
          <li class="views-row views-row-10 views-row-even views-row-last">  
  <span class="views-field views-field-title">        <span class="field-content"><a href="/article/2018/06/26/blessings-fog-and-uncertainty-joy-exploring-unknown">The Blessings of Fog and Uncertainty: The Joy of Exploring the Unknown</a></span>  </span>  
  <div class="views-field views-field-tid">        <span class="field-content"><a href="/authors/edwin-torkelsen">Edwin Torkelsen</a></span>  </div></li>
      </ul></div>    </div>
  
  
  
      
<div class="more-link">
  <a href="/recent_posts">
    more  </a>
</div>
  
  
  
</div></div></div></div></div>
  
</div>
  <div id="block-block-10" class="block block-block region-odd odd region-count-3 count-3">

  <div class="block-title"><h3>Support Spectrum</h3></div>

  <div class="content">Thank you for making your generous gift.
Your donation will help independent Adventist journalism expand across the globe.<br>
<br>
<a href="https://app.etapestry.com/onlineforms/AssociationforAdventistForums/donatenow.html" target="_blank"><h3>DONATE NOW!</h3></a></div>
  
</div>
  <div id="block-block-16" class="block block-block region-even even region-count-4 count-4">

  <div class="block-title"><h3>Newsletter</h3></div>

  <div class="content"><div class="newsletter-form">
<form method="post" action="https://oi.vresp.com?fid=8e99d2c105" target="vr_optin_popup" onsubmit="window.open( 'http://www.verticalresponse.com', 'vr_optin_popup', 'scrollbars=yes,width=600,height=450' ); return true;" >
  <div>
    <label style="color: #333333;">Email:</label>
    <input name="email_address" size="25" style="margin-top: 5px; border: 1px solid #999; padding: 3px;"/>
    <input type="submit" value="Sign Up" style="margin-top: 5px; border: 1px solid #999; padding: 3px;"/>
  </div>
</form>
</div></div>
  
</div>
  <div id="block-block-23" class="block block-block region-odd odd region-count-5 count-5">

  <div class="block-title"><h3>Ads</h3></div>

  <div class="content"><div style="text-align: center"><script type="text/javascript"><!--
google_ad_client = "ca-pub-4279063372898045";
/* 250x250, created 2/8/08 */
google_ad_slot = "5792579028";
google_ad_width = 250;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>
  
</div>
  <div id="block-quicktabs-3" class="block block-quicktabs region-even even region-count-6 count-6">

  <div class="block-title"><h3>Organizations</h3></div>

  <div class="content"><div id="quicktabs-3" class="quicktabs_wrapper quicktabs-style-arrows"><ul class="quicktabs_tabs quicktabs-style-arrows"><li class="qtab-0 active first last"><a href="/article/2018/06/28/return-our-lord-jesus?quicktabs_3=0#quicktabs-3" id="quicktabs-tab-3-0" class="qt_ajax_tab active">Upcoming Events</a></li></ul><div id="quicktabs_container_3" class="quicktabs_main quicktabs-style-arrows"><div id="quicktabs_tabpage_3_0" class="quicktabs_tabpage"><div class="view view-events view-id-events view-display-id-block_1 view-dom-id-6ee367bad6424bb3ef0cd86d1294adfb">
    
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Sat, 08/04/2018</span></span>  </span>      |  
  <span class="views-field views-field-title-1">        <span class="field-content">San Diego Adventist Forum</span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://sandiegoadventistforum.org/node/534">Summer 2018 Meeting with Voices of Our City</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content">Steph Johnson and the Voices of Our City Choir and Band</span>  </div>  </div>
  <div class="views-row views-row-2 views-row-even">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Sat, 08/04/2018</span></span>  </span>      |  
  <span class="views-field views-field-title-1">        <span class="field-content">San Diego Adventist Forum</span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://sandiegoadventistforum.org/node/534">Summer 2018 Meeting with Voices of Our City</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content">Steph Johnson and the Voices of Our City Choir and Band</span>  </div>  </div>
  <div class="views-row views-row-3 views-row-odd">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Tue, 10/02/2018</span></span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="https://spectrummagazine.org/event/escape-line-book-release-and-celebration">The Escape Line Book Release and Celebration</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content"></span>  </div>  </div>
  <div class="views-row views-row-4 views-row-even">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Sat, 10/13/2018</span></span>  </span>      |  
  <span class="views-field views-field-title-1">        <span class="field-content">San Diego Adventist Forum</span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://sandiegoadventistforum.org/node/535">Fall 2018 Meeting with Dr. Donald Casebolt</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content">Dr. Donald Casebolt</span>  </div>  </div>
  <div class="views-row views-row-5 views-row-odd">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Sat, 10/13/2018</span></span>  </span>      |  
  <span class="views-field views-field-title-1">        <span class="field-content">San Diego Adventist Forum</span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://sandiegoadventistforum.org/node/535">Fall 2018 Meeting with Dr. Donald Casebolt</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content">Dr. Donald Casebolt</span>  </div>  </div>
  <div class="views-row views-row-6 views-row-even">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Sat, 01/19/2019</span></span>  </span>      |  
  <span class="views-field views-field-title-1">        <span class="field-content">San Diego Adventist Forum</span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://sandiegoadventistforum.org/node/536">Winter 2019 Meeting with Clifford Goldstein</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content">Clifford Goldstein</span>  </div>  </div>
  <div class="views-row views-row-7 views-row-odd views-row-last">
      
  <span class="views-field views-field-field-event-date-value">        <span class="field-content"><span class="date-display-single">Sat, 04/20/2019</span></span>  </span>      |  
  <span class="views-field views-field-title-1">        <span class="field-content">San Diego Adventist Forum</span>  </span>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="http://sandiegoadventistforum.org/node/537">Spring 2019 Meeting with Christine Whitworth</a></span>  </div>  
  <div class="views-field views-field-field-event-speaker-value">        <span class="field-content">Christine Whitworth</span>  </div>  </div>
    </div>
  
  
  
  
  
  
</div></div></div></div></div>
  
</div>
  <div id="block-block-17" class="block block-block region-odd odd region-count-7 count-7">

  <div class="block-title"><h3>Connect with Spectrum</h3></div>

  <div class="content"><div class="row">
<div class="cell"><a href="https://www.facebook.com/spectrum.magazine" target="_blank"><img src="/sites/all/themes/blue_prism/img/facebook.png" alt="Social media link: Spectrum Magazine on Facebook"></a></div><div class="text"><a href="https://www.facebook.com/spectrum.magazine" target="_blank">Facebook</a></div>
<div class="cell"><a href="https://twitter.com/spectrummag" target="_blank"><img src="/sites/all/themes/blue_prism/img/twitter.png" alt="Social media link: Spectrum Magazine on Twitter"></a></div><div class="text"><a href="https://twitter.com/spectrummag" target="_blank">Twitter</a></div>
</div>
<div class="row">
<div class="cell"><a href="https://www.flickr.com/photos/spectrummagazine" target="_blank"><img src="/sites/all/themes/blue_prism/img/flickr.png" alt="Social media link: Spectrum Magazine on Flickr"></a></div><div class="text"><a href="https://www.flickr.com/photos/spectrummagazine" target="_blank">Flickr</a></div>
<div class="cell"><a href="https://spectrummagazine.org/spectrum_rss_feeds"><img src="/sites/all/themes/blue_prism/img/rss.png" alt="Social media link: Spectrum Magazine RSS Feeds"></a></div><div class="text"><a href="https://spectrummagazine.org/spectrum_rss_feeds">RSS</a></div>
</div></div>
  
</div>
  </div>

          <div id="footer" class="clear">
                    <div id="block-block-22" class="block block-block region-odd even region-count-1 count-8">


  <div class="content"><div style="text-align: center"><script type="text/javascript"><!--
google_ad_client = "ca-pub-4279063372898045";
/* 728x90, created 2/8/08 */
google_ad_slot = "6659931591";
google_ad_width = 728;
google_ad_height = 90;
//-->
</script>
<script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div></div>
  
</div>
        
        <div id="footer-message">Copyright &copy; 2018 Adventist Forum. All Rights Reserved.</div>

      </div>
      </div>

  <script type="text/javascript" src="https://spectrummagazine.org/sites/default/files/js/js_d660287265468ae7613a668ff5cd9a87.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","jcarousel":{"ajaxPath":"\/jcarousel\/ajax\/views"},"cron":{"basePath":"\/poormanscron","runNext":1530207372},"uc_ajax_cart":{"CALLBACK":"\/uc_ajax_cart\/add\/item","SHOW_CALLBACK":"\/uc_ajax_cart\/show","CART_LINK_CALLBACK":"\/uc_ajax_cart\/addlink","BLOCK_UI":1,"TIMEOUT":2000,"UPDATE_CALLBACK":"\/uc_ajax_cart\/update","UPDATE":0,"CART_VIEW_ON":0,"SHOW_VIEW_CALLBACK":"\/uc_ajax_cart\/show-cart-view","TRACK_CLOSED_STATE":0,"INITIAL_CLOSED_STATE":0,"CART_PANE_EFFECT":0,"CART_PANE_EFFECT_DURATION":200,"HIDE_CART_OPERATIONS":0,"COLLAPSIBLE_CART":0,"ADD_MESSAGES":["Adding product to cart..."],"ADD_TITLE":"","REMOVE_MESSAGES":["Removing product from cart..."],"REMOVE_TITLE":"","UPDATE_MESSAGES":["Updating cart..."],"UPDATE_TITLE":"","CART_OPERATION":""},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"quicktabs":{"qt_2":{"tabs":[0]},"qt_3":{"tabs":[{"vid":"events","display":"block_1","args":[],"get_displays":"vdisp_0","title":"Upcoming Events","weight":"-100","type":"view"}]}},"views":{"ajax_path":"\/views\/ajax","ajaxViews":[{"view_name":"events","view_display_id":"block_1","view_args":"","view_path":"node\/8857"}]},"CToolsUrlIsAjaxTrusted":{"\/article\/2018\/06\/28\/return-our-lord-jesus":true}});
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","/sites/default/files/googleanalytics/analytics.js?Y","ga");ga("create", "UA-8866094-1", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
  <script type="text/javascript" src="https://spectrummagazine.org/sites/default/files/js/js_d769a6979275940cbbcad63bf96bc134.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
AudioPlayer.setup("/sites/all/libraries/audio-player/player.swf", {"autostart":"no","loopaudio":"no","animation":"yes","remaining":"no","noinfo":"no","initialvolume":"60","buffer":"5","encode":"no","checkpolicy":"no","rtl":"no","width":"290","transparentpagebg":"no","pagebg":"FFFFFF","bg":"E5E5E5","leftbg":"CCCCCC","lefticon":"333333","voltrack":"F2F2F2","volslider":"666666","rightbg":"B4B4B4","rightbghover":"999999","righticon":"333333","righticonhover":"FFFFFF","loader":"009900","track":"FFFFFF","tracker":"DDDDDD","border":"CCCCCC","skip":"666666","text":"333333"});
//--><!]]>
</script>

</div>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"3c9980e3ed","applicationID":"610667","transactionName":"b1IDN0oHD0ZUUkFcVlYYIABMDw5bGl9aUVxnRwAEXTkXXFBG","queueTime":0,"applicationTime":548,"atts":"QxUAQQIdHEg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
